fbpx
  Monday, 12 April 2021
  1 Replies
  1.9K Visits
0
Votes
Undo
  Subscribe
I am running Ableton 10.1.30 on a 2019 MacBook Pro. As I have some external hardware, I am running this through an MX-1, and using this MX-1 as the audio interface via USB to my MacBook and Ableton Live. I am also using a Midiface 16x16 as the midi interface, with each instrument given it’s own midi port.

I am having some serious timing and playback issues with my external hardware, that I cannot put my finger on a solution for.

To test the midi timing, I am using a Roland System 8 and a Roland TR-8S through the MX-1. The System 8 is going into Port 3 of the midi interface, and is set to midi channel 3. The TR-8S is going into Port 10 of the midi interface, and is set to midi channel 10.

To set up the System 8, I am doing the following:
Create a midi track
Set MIDI From to MIDIFACE Ch 3
Set MIDI channel to 3

At this point, if I play notes on the System 8 it registers them in Ableton as Midi In data, but there is no audio, so I then:
Load an external Instrument onto the MIDI track
Select the Midi To feed as Midiface Port 3, but set the midi channel as No Output (see further down for the reason behind this)
Set the Audio From as 13/14 (make sure MX-1 is selected as Ableton audio input source)
Record Arm the Midi track
Set a clip recording and play some notes in from the System 8 - this will record Midi data into the clip as you would expect
Disarm the Track Record button immediately, or you will get a massive amount of midi and audio overload that only stops if you disarm the Track Record button

To get the Midi data to play back I then:
Go to the External Instrument
Set the MIDI To to Midiface Port 3
Set the Midi Channel to 3
This then gives correct midi playback

To then record Midi data into another clip:
I go to the External Instrument and set the Midi Channel to No Output - if you don’t, this will again create the midi and audio overload
Record Arm the Midi track
Press record on a clip and record a pattern
Disarm the Track Record button
Go to the External Instrument and set the Midi Channel to 3 so I can listen to the midi data in the clip playing back.

This overload of incoming Midi date also occurs when not recording into a clip while the Midi track is armed to record but not recording, and again, only stops when you disarm the record button on the Midi track or change the midi channel

If you then play back a recorded clip with the track record button disarmed, it will play back perfectly

The thing I don’t understand is why, when the track record button is armed, and the correct midi channel is selected on the external instrument, that there is a mass of audio and midi overload - I can provide a video clip to show you this happening in real time, if needed.


I then repeated the procedure to record patterns programmed into my TR-8S

One of the key things I noticed, was that, to have the audio from the MX-1 play in time with the Ableton metronome, I had to go in to Midi Preferences, and set the Output: MX-1 Midi Clock Sync Delay to -85ms so that the audio would play back in time, although each time I restart the song it changes - at first it was -180ms, then it went down to -90ms, and now it is -85ms, which is a pain in the arse to keep having to adjust. Likewise, to get the audio to playback through the External Instrument in time, I have to adjust Hardware Latency value in the External Instrument to 40ms, although again this jumps around from 25-90ms as and when it wants, which is a real pain, as it means constantly adjusting the timing of everything, which really slows my creative process down.

Another issue I am having is that when I record the midi data into a clip, it does not record in time - I find that is almost 5/16ths of a beat late, when recorded in at 120bpm. This then means having to go back into the clip and quantise everything, which again slows the whole creative process down.

Finally, every time I create a new empty midi track, it somehow affects the hardware latency of each external instrument, making me have to go back into them and adjust the hardware latency of each external instrument again.


So, in summary, my key issues are:
An overloading of audio and midi data when I record a midi clip from an external instrument if the midi channel in the Midi To Channel box is set correctly
The midi data being recorded from an external instrument being almost 5/16ths of a beat out of time, and having to be manually adjusted to get it to play back in time.
The fact that the Midi Clock Sync Delay in the MX-1 Output Midi Port in Midi Preferences changing all the time
The fact that the hardware latency of each external instrument keeps changing all the time.

Can anybody help me with this? Surely Ableton Live must work better than this with external hardware - I have watched loads of people playing live with hybrid systems of hardware and Ableton Live (Saytek, for example), and they don’t have these problems.

I also tried the same thing in Logic Pro X. I created an external instrument, set the midi and audio channels correctly, and then tried to input midi data, but again it just fired a massive amount of midi data into Logic - this can be seen in this video that I uploaded to YouTube - https://www.youtube.com/watch?v=LMvHqRD6GRU
7 months ago
·
#8734
0
Votes
Undo
Turn off "LOCAL" on your keyboards.
  • Page :
  • 1
There are no replies made for this post yet.
Be one of the first to reply to this post!