1. Clément
  2. MIDI Hardware
  3. Sunday, 29 April 2018
  4.  Subscribe via email
Hi! I have a hardware sequencer (Synthstrom Deluge) controlling a hardware sampler (Roland SP-404) through a cable, simple OUT-to-IN connexion. All goes well except, from time to time, all sound from the SP-404 would go off at once, until the next trigg. It is not a polyphony issue within the SP-404, I checked. When not connected to MIDI, this problem doesn't happen.

Where shoud I look? :)
  1 Avenue de Bouvines, 75011 Paris-11E-Arrondissement, France
Visit 
Comment
There are no comments made yet.
Accepted Answer Pending Moderation
0
Votes
Undo
Have you checked the cable. Might be an occasionally faulty connection somewhere? Even better, have you tried a different cable?

When it 'stops', does sending device give indication that it's still sending? Does receiving device give any indication that it's still receiving data, even if it's not making any sound?

When it stops, is this at any particular distance into the piece (of music ?) - or is this totally random?

Geoff
Comment
There are no comments made yet.
  1. more than a month ago
  2. MIDI Hardware
  3. # 1
Accepted Answer Pending Moderation
0
Votes
Undo
Hi Geoff,
On your advice I used a different cable, then another from another brand, it doesn't seem to be it.
Yes, the sending machine (sequencer) keeps activating all the triggs, and the receiver (sampler) responds to everyone of them. it's just that continuing, long sounds are simultaneously interupted, as if "ALL NOTES OFF" was sent.
This happens at different moments in the song. There seems to be a pattern but I have not yet identified it.
Thank you for your help!
Comment
There are no comments made yet.
  1. more than a month ago
  2. MIDI Hardware
  3. # 2
Accepted Answer Pending Moderation
0
Votes
Undo
Hello,

On the basis of the new information, it seems likely that the problem is nothing to do with the normal operation of either unit (sending and receiving) or of the connection (cable). The midi link seems OK.

I'd be wondering about settings within the sampler. On the basis of what you say, the sampler does not seem to like sustained notes. You need to check the manual, and any settings that you can configure, to see if there's a maximum note length. Such a thing could be considered a 'protection' against the problem of a note/sound being left 'on' accidentally.

You said in your fist message that it wasn't a polyphony matter? The fact that you checked this suggests that you were wondering about such things. Of course, one of the reasons why the unit might cut off a long note IS to protect polyphony. Depending on the sample, the envelope, etc, you could have a long 'sound' playing that continues to use (waste) system resources even though no audible sound is apparent.

Why and how did you determine that polyphony was NOT a possible problem?

Maybe there is a setting - something like - Maximum Note length?

How long are the notes that are being cut off? How long are they cut off at? Do other notes (normal length) playing at the same time, also get cut off?

Oh, it seems less likely, but it's not impossible that the Sequencer may have a setting (for similar reasons) that is causing the problem. So check settings on that too.

Geoff
Comment
There are no comments made yet.
  1. more than a month ago
  2. MIDI Hardware
  3. # 3
Accepted Answer Pending Moderation
0
Votes
Undo
Thanks a lot, Geoff !
Sounds like I have a bit of work then :D
Polyphony didn't seem the problem because I respect the maximum number of engaged audio channel, that is: 12 (6 stereo) - and I'm only using 8 (4 stereo). Also, when I leave the sampler unconnected to MIDI it goes on uninterupted forever.
I'll check with the manuals again (the Deluge's user manual is not very clear about many things) and find out if there is such a setting. I don't remember seeing anything in it about it but I might have missed it.
I'll get back here to report my solution if I find one ^^
Comment
There are no comments made yet.
  1. more than a month ago
  2. MIDI Hardware
  3. # 4
  • Page :
  • 1


There are no replies made for this post yet.
Be one of the first to reply to this post!