The MIDI Forum

  1. Andrew
  2. MIDI Software
  3. Tuesday, 11 September 2018
  4.  Subscribe via email
I'm having trouble with Chrome and Opera freezing when using Web MIDI pages on a Windows 10 machine. It mostly works, but frequently unplugging a MIDI device causes the browser to freeze. It seems to happen with all Web MIDI pages, including my own in progress here: https://warbl.xyz/configure.html, and the Web MIDI API example page here: http://webaudiodemos.appspot.com/monosynth/index.html

The problem does not occur when using Firefox with the WEB Midi plugin, nor does it happen on ios using the WEB Midi browser app: https://itunes.apple.com/us/app/web-midi-browser/id953846217?mt=8

I'm wondering if anyone has suggestions for preventing this? Thanks!
Comment
There are no comments made yet.
Accepted Answer Pending Moderation
0
Votes
Undo
Apparently, there's nothing that you (as a user or programmer) can do.

(… Well, stop unplugging devices while they're still being used.)
Comment
There are no comments made yet.
  1. more than a month ago
  2. MIDI Software
  3. # 1
Accepted Answer Pending Moderation
0
Votes
Undo
Does that mean that it's a common problem? I'm okay with that, I mostly just want to make sure it's not unique to my situation. The device is one that I made using the Arduino MIDIUSB library, and my only concern is that the device may be doing something wrong. Thanks!
Comment
There are no comments made yet.
  1. more than a month ago
  2. MIDI Software
  3. # 2
  • Page :
  • 1


There are no replies made for this post yet.
However, you are not allowed to reply to this post.