The MIDI Forum

  1. Tadej
  2. Creating with MIDI
  3. Sunday, 02 February 2020
  4.  Subscribe via email
I am quite new to MIDIs so perhaps I am missing something obvious here...

I have quite many MIDIs of different songs downloaded on my desktop and the note patterns in them range from complex to pretty simple.
These MIDIs rarely exceed the file size of 50kB.

I tried working on a MIDI of my own, but it seems that a specific note pattern (that is more or less used throughout the whole MIDI) ends up taking up more than 90 percent of the file size (the file size is 2 MB). This MIDI is about 90 seconds long, like most of the others on my desktop, so there must be some weird property I don't understand.
I need the MIDI to be about the same file size as a the other ones (around 50kB or less).

Just this note pattern repeated twice (a length of 5 seconds) produces a file size of 46kB, which is even higher than most full length MIDIs I have.

Is there something that I can do to make these notes a smaller file size?

I put the note pattern as an attachment, so you can check it out, if you wish to.
Attachments (1)
Comment
There are no comments made yet.
Accepted Answer
Accepted Answer Pending Moderation
0
Votes
Undo
Right, I can see the problem, But I cannot comment on why the extra info is there. It might be quite legitimate, although I doubt it.

I attach a file for you, 1Example.txt This file is the result of running a prog called DECODE on your original file, and it produces a text version of the data, so you can see exactly what's there.

The file contains two different types of 'extra' data. Firstly, there's quite a lot of 'sequencer specific' data which might or might not be important. Secondly, there's a LOT of Pitch Wheel data, including a large proportion which seems to be all at the end of the file and, in effect, doing nothing useful.

You need to look at all this stuff and decide why it's there, and proceed from there. If it would help, I can create a variant of your original midi file with all this removed, just the notes remaining, or remove all the stuff that seems, to me, to be unhelpful.

Geoff
Attachments (1)
Comment
There are no comments made yet.
Accepted Answer Pending Moderation
0
Votes
Undo
Thanks for the response

There is probably no need for you to "cleanse" it for me. I can just remake the pattern in an new track, so it is fresh, and it should probably work fine.

Is there a reason why this garbage data would show up? I'm making MIDIs in Anvil Studio. I've been messing around with the notes volume quite a lot, so perhaps the settings didn't quite dissapear?
This extra data seems to be present in the whole track. Even deleting all the notes leaves all the garbage data still inside,so a new fresh track will have to be remade. Not really a problem since it is just a repeating pattern, but it could be a problem if it appears in more important tracks.
Comment
There are no comments made yet.
Accepted Answer Pending Moderation
0
Votes
Undo
I would not suggest that any of the data is 'garbage', merely totally superfluous.

I've no idea what the 'sequencer specific' data is, it's not SYSEX. I assume your manual will say. There's not too much of that, and once it's done, then it stops.

The part of the file down to Meta Time 7680 seems OK, just normal notes etc, but then all the Pitch Wheel data starts, and it's just a flood of that, mostly all exactly the same, incl the Meta Time, so it's doing nothing useful. I'd wonder if there was something wrong with the Pitch Wheel, or al least the sensitivity of it which must be set to extreme at least. Maybe as soon as you touch the PW, then the flood of data starts, and just keeps going. Can you disable the PW, or reduce (massively) the sensitivity?

We had another case a while back where someone was getting masses of spurious data - again I think from PW - but this was happening in the middle of playing and was causing problems with the playback. You don't seem to get that, as it's happening at the end. So it seems?

Geoff
Comment
There are no comments made yet.
Accepted Answer Pending Moderation
0
Votes
Undo
The most I did with pitch is move notes accros the "pitch lines" (or however you call them), and I do that quite frequently, so I kind of doubt that this is the reason. I do faintly remember missclicking something somewhere, but don't know exactly what. Granted, that may not be what caused this problem at all.

Still, I did what I said in the last post, and remade a new track from scratch and now the file size is only 20kB, so that solution worked. i doubt this problem was a bug, but was probably some error I made.

Thanks for you help
Comment
There are no comments made yet.
Accepted Answer Pending Moderation
0
Votes
Undo
I understand the problem is resolved, but in case Geoff or anyone else is curious about Sequencer Specific meta events...

A Sequencer Specific meta event is a similar concept to a System Exclusive message:

The contents of either a System Exclusive message or a Sequencer Specific meta event begin with a 1-byte (or if the first byte is zero, a 3-byte) Manufacturer ID. The contents after the Manufacturer ID are defined by that manufacturer.

A System Exclusive message is sent to the MIDI output device. A Sequencer Specific meta event (like all meta events in a MIDI file) is only visible to the software that reads the MIDI file, it doesn't send anything to the MIDI output device.

According to the Anvil Studio User's Guide, "Anvil Studio stores Sequencer-Specific MIDI events to remember things like links to audio files and some staff note properties."

(Looking at the example MIDI files on the Anvil Studio website and Tadej's example MIDI file in this thread, it appears Anvil Studio's Sequencer Specific meta events' contents always begin with hex 05 0F. However, hex 05 is the Manufacturer ID for Passport Designs. I don't know if this means Anvil Studio uses the same format of Sequencer Specific meta events that some Passport Designs software uses.)
Comment
There are no comments made yet.
  • Page :
  • 1


There are no replies made for this post yet.
Be one of the first to reply to this post!