1. Pavel
  2. MIDI Hardware
  3. Sunday, 07 June 2020
  4.  Subscribe via email
Hello,
I have a quite specific question that keeps me awake at night for a couple of weeks now:
I'm using a vintage guitar midi controller (1986 Ibanez IMG2010) with a its companion 24-pin Ibanez MC1 midi converter and a Yamaha TX81Z tone generator. So definitely an homage 80's setup which works amazingly! :D However, when I connect the midi out from the MC1 converter to my old and trusty M-Audio 1010 interface with a standard 5 pin midi cable and play through some virtual instruments hosted in Cakewalk Sonar, all of the note-off are very abrupt and clicky (since audibly the notes are cut off with no mercy and the natural fade out).
If I record a passage and play it back, everything is smooth as glass. If I play or record a passage using my midi keyboard, everything is smooth as glass... So my guess is that MC1 sends out some vintage note-off message that newer software does not like at all. Are there any solutions to this unfortunate problem?
Thank you very much in advance!

p.s. Here's a screenshot of MIDI OX capturing a note-on / note-off sequence played with the IMG2010 guitar, in the midst of the spamming of ''Active Sensing'' :D
MIDIOX.jpg
Attachments (1)
Comment
There are no comments made yet.
Accepted Answer Pending Moderation
0
Votes
Undo
Sorry to hear this is keeping you awake at nights. I hope not TOO literally?

Thanks for the Midi-Ox output, which is always useful.

I'd suggest that the Note On and Note OFF seem quite normal, although I cannot tell too much regarding the timing. BUT, why is the CC (Controller) All Notes Off there, this is at least total Overkill, and quite unnecessary. Is something putting this in after EVERY note off? And almost immed after?

What happens if you play a number of notes, does every one have an immed All Off. I'd need to dig into this, but the All Off may have the effect of killing any normal decay, which clearly you do NOT want.

All Off is something that you might use at the VERY END of a piece, involving lots of notes and the possibility of some that may have not had the usual Note Off. Even then, not so immed. What is adding this is, can you turn it off?

Geoff
Comment
There are no comments made yet.
  1. more than a month ago
  2. MIDI Hardware
  3. # 1
Accepted Answer Pending Moderation
0
Votes
Undo
Further to the above, I still think that the All Notes Off does NOT need to be there, however you should also check settings of the Hold or Sustain Controller (#64) and make sure that it is ON (data range 0-63 is OFF, 64-127 is ON). Add this controller in set to ON at the start to make sure. Even if the All Notes OFF is still there, it may not do anything if sustain is ON.

Geoff
Comment
  1. SysExJohn
  2. 1 month ago
  3. #20
I agree with Geoff's answer, the CC121 is switching off all the sounds.
It really shouldn't be there and is definitely not normal MIDI behaviour.
JohnG.
There are no comments made yet.
  1. more than a month ago
  2. MIDI Hardware
  3. # 2
Accepted Answer Pending Moderation
0
Votes
Undo
I've just been looking at the manual for the MC1 via the web.

Are you using the FS1M foot switch with the MC1? Page 16 of the manual refers to this, and the operation of the footswitch seems to relate closely to the sustain setting. The manual does not say what the default setting is without the footswitch, but it might be OFF, in which case this could be the source of your problem. If you do not have the footswitch, you need to find a way to set sustain to ON, I've not read the complate manual!

Geoff
Comment
There are no comments made yet.
  1. more than a month ago
  2. MIDI Hardware
  3. # 3
Accepted Answer Pending Moderation
0
Votes
Undo
Hello Geoff and John!

Thank you for very detailed answers! It helps a lot to know that I'm not alone, staring into the darkness of the MIDI abyss :)

So here is a more detailed explanation of the behavior of the unit:
1) A note is played, as soon as the said note is stopped, a Note-Off message is sent along with the All Note Off message.
2) If another note is played, while the first note is still sustaining, everything works as intended; the notes are allowed to fade out gracefully (as long as at least one note is still sustaining), then the deadly All Note Off is sent.
3) If the Hold function is used (by activating the FS1M switch, which took me 6 months to find :) ), the unit behaves like a piano sustain pedal (allowing me to stack multiple notes, even when my finger is off the string), but the infamous All Notes Off is still sent... Also, activating the Hold function by default, will render playing the instrument almost impossible, since every note will keep resonating (while the All Notes Off will still be sent out...)

I will read the manual again, but I'm not sure that there's anything in the MC1 unit that is user-configurable, unfortunately...

Thank you again very much, I really appreciate your help! :)
Comment
There are no comments made yet.
  1. more than a month ago
  2. MIDI Hardware
  3. # 4
Accepted Answer Pending Moderation
0
Votes
Undo
Hello again :)

As I suspected, the MC1 unit is non user-configurable when it comes to the CCs that the unit sends.
However, after experimenting a bit a found a workaround for my problem: I just use a MIDI events filter that is supplied with Cakewalk Sonar on every track that will be used with the Ibanez IMG2010. I basically filter out the CC #123 and everything works fine! :D
Here's a screenshot of the setting, in the unlikely event that someone will have an identical situation to mine sometime in the future:
MIDIevents_Filter.jpg

Thank you again for your help!
Attachments (1)
Comment
There are no comments made yet.
  1. one week ago
  2. MIDI Hardware
  3. # 5
  • Page :
  • 1


There are no replies made for this post yet.
Be one of the first to reply to this post!