The MIDI Forum

  1. Steve
  2. Creating with MIDI
  3. Monday, 21 August 2017
  4.  Subscribe via email
Hi - I'd be really grateful for any help with this.

I've recently bought a Kawai N37 digital piano. I want to control this using Cubasis2 on iPad.

I have a seven track project which works fine with the Cubasis internal instruments. When I set the midi outs (on Cubasis) to seven tracks on my piano, which has a 16 track multitimbre facility and 350 instruments, I can hear all seven tracks but they are each played by the default piano sound. I'm looking for a way to tell it to use different instruments on each track.

I also use a Korg microstation. This works fine with the cubasis as I'm able through the display to say which sounds on the Korg I want to use. The Kawai doesn't seem to have these features which is why I'm looking to Cubasis to do it.

Any help much appreciated
Thanks
Steve
  East Sussex, UK
Visit 
Comment
There are no comments made yet.
Accepted Answer Pending Moderation
0
Votes
Undo
Hello,
Seems like the Dig Piano - Kawai - is not recognising, or not receiving, Program Change instructions.

You need to check that the Kawai is able to receive PC (Program Change) and that it uses the normal codes. You need also to make sure that the Instrument number is appropriate (i.e. the Software process may use GM patch numbers, the Kawai may use something else).

You have the manuals!

If the Korg DOES work, then seems PC commands are being sent.

If you can save the data as a midi file, and send me it, I can look inside and see EXACTLY what's there. That would be a help.

Also, check the Patches/Instruments you are using. Is the Patch ## the same for all three units (Software, Kawai, Korg) - check this in the manuals. However, if this was the total answer, I'd expect the Kawai to be playing different things on each channel, even if the wrong things, but not the SAME patch on ALL channels.

Geoff
Comment
There are no comments made yet.
  1. more than a month ago
  2. Creating with MIDI
  3. # 1
Accepted Answer Pending Moderation
0
Votes
Undo
Just looked at manual on line for kawai CN37. Is it CN37, you originally put N37?

According to Program/Instrument numbers, the Program change system is different on the unit. Almost all settings require a BANK select AND a Program Number. So the Kawai needs two commands. The other units prob work fine with one command (Program Change) only.

Geoff
Comment
There are no comments made yet.
  1. more than a month ago
  2. Creating with MIDI
  3. # 2
Accepted Answer Pending Moderation
0
Votes
Undo
Hi Geoff - sorry I didn't get back. I sort of gave up with this and didn't see your replies. many thanks for engaging with this. After that question I went back to Kawai through their European branch and they were pretty clueless - and, actually, indifferent. No-one there was able to achieve the simple task of getting different instruments to sound on different tracks using a sequencer.

I've now returned to the problem and am still getting nowhere.
I found that I could set program changes through the Cubasis 2 App. but it's very fiddly because they have to be drawn onto the screen and cannot be input numerically.

I still believe there must be a way to use the Kawai to make this work. It's possible to record tracks directly onto a USB stick but that doesn't allow any editing, not even balancing the different tracks volume wise!

I can play around with program numbers but I'm still failing to make it play more than one different sound at a time.

I'm not sure that I know how to send the data as a midi file.

I found a document on from Kawai on midi but I still don't know what to do with it. Attached. Whoops, I got a message saying that file was unsupported.
It's here:

https://www.kawai-global.com/data/manuals/CN37_EN_MIDI_Settings_Manual.pdf

Apologies again for not seeing your post.

Steve
Comment
There are no comments made yet.
Accepted Answer Pending Moderation
0
Votes
Undo
Hello,

I'm still here!

I've d/l the manual, I'll have a look at it.

It would have been nice to see the actual midi being sent, but it's easy for me to say that, but not so easy to achieve if you don't know what you're doing.

It may be that the piano sound is the default instrument for all the channels, and you're not sending program change commands to set different instruments, or the messages you do sent are not getting there (maybe they all go to the wrong channel).

Can you play a pre-made midi file. One thing that might help is that I send you a known midi file, you play it, and report on the sounds made? OK?

Geoff
Comment
There are no comments made yet.
Accepted Answer Pending Moderation
0
Votes
Undo
The manual you refer to above is onlt a part of the docs, this one seems to refer mainly to certain setup procedures regarding midi. These MIGHT well contribute to your problem, but the details given for the different settings are not clearly explained, so I'm not sure. Some quick experimentation would clarify I'm sure.

The bulk of the detail in in a much larger Owners Manual, this is also available via the web. I've had a quick look at that, specifically the Program List.

I must have looked at this before, hence my comments a year ago about the Program Change differences.

Looking at this again, there is an initial bank of 128 sounds, which all expect a LSB Bank Select of 0 (zero). This may well be satisfied with defaults, i.e. doing JUST the Program Change instruction SHOULD select an instrument. You would need to have the Midi Settings 'Multi Timbral' item set as on1 (on one). I think that having this as 'off' would mean that multi timbral would not work at all, and the third setting 'on2' (on two) would mean that all program changes would involve three midi commands, for MSB, LSB and PC, and these settings are quite different from anything else.

The 'on1' are not ideal in any event. There are 128 sounds all using LSB of 0 and Program Change of 1 to 128. The start of this list is close to GM sounds, but the further down the list you go, the further you get from GM. So, a GM midi file may well 'sort-of' work, but ideally you'd need to change all the instrument assignments to suit the Kawai. Instrument 1 is standard piano, and will be the initial default for all channels. Oh, the list continues with further sounds after the initial 128, now requiring the LSB value of 1, then there are more sounds needing a LSB of 2, and certainly these would be accessible ONLY with the full/correct Kawai version of Program Change. In some ways, this system may be leaning towards GS/GM2, but I don't think they're right for that either.

In your case, it appears that PC (program change) is not being done at all. This would be the case if your keyboard is set to on2, so that's one place to start.

Geoff
Comment
There are no comments made yet.
  • Page :
  • 1


There are no replies made for this post yet.
However, you are not allowed to reply to this post.