The MIDI Forum

0
Votes
Undo
  1. Steve
  2. MIDI Software
  3. Wednesday, 25 March 2020
  4.  Subscribe via email
Hi, even though I've been utilizing MIDI for many years, I've decided to start getting into MIDI file creation. It's not just a matter of recording your tracks and exporting as a MIDI file!!
I've learned to create a 'Header' on each track to create the required CC information, but here's my problem.
I've opened up a pre recorded midi file to work on. I've managed to input the program change info so that it uses the sounds that I want, but I have a track with strings (General MIDI No.49) that seem to have a slow attack on them. If I delete the header, they play normal, but as soon as I add a header, the attack is back! I haven't added any attack information.
Any thought would be gratefully received!:)
Attachments (1)
Comment
There are no comments made yet.
Accepted Answer Pending Moderation
0
Votes
Undo
Hello,

Have you got the GM number right?

The GM sound list runs 1 to 128, and 49 is Strings, and 50 is 'slow' syrings, i.e. with a slow attack. But the numbers that appear in the midi file are always 1 less, i.e. running 0 to 127, and the standard strings will therefore appear as 48 and the slow strings will be 49.

This will not be anything to do with the header, but it might be to do with whatever manipulation you're doing to the file when you do whatever with the header.

If there;s still a problem, please attach the midi file that has the problem.

Geoff
Comment
There are no comments made yet.
  1. 4 days ago
  2. MIDI Software
  3. # 1
  • Page :
  • 1


There are no replies made for this post yet.
Be one of the first to reply to this post!