The MIDI Forum

  Friday, 15 January 2021
  1 Replies
  4.7K Visits
OK, new to this forum but NOT new to Midi generally but recent events totally perplexing me, namely I can't get any USB Midi drivers to work with W7 / W10

I have a much maligned Swissonic USB>midi which worked out the box a couple or so years ago on my W7 setup. I used it successfully for Dumping SYSEX files in MIDIOX and other Sysex apps and linked to CUBASE LE4. It seems to have utilised the ROLAND UM-1G driver. Nothing has changed in my setup, but when I went to use it the other day it does not show up and the now Windows interpreted 'USB Audio device' driver fails to load and has a yellow triangle in device manager. So I downloaded a newer Roland UM-1G driver but no use - it stalls when asking to plug the USB in. I tried installing direct via the install *.inf file but am told this device does not install in this manner. Same happens on two other clean install W7 machines and my clean W10 laptop. What does work is on an XP laptop but where again shows as a USBAudio device.

Now when I run up Cubase on the W7 install I see that the once successfully connected as UM-1G is showing as 'Not Present'' in MIDI Setup and a video I did to show SYSEX Dump on my BOSS ME-5 just 18 months ago shows it again connected as 'Connected device s UM-1G' again.

Have Googled everything around this issue and nothing has helped.

So the Swissonic works (in XP) and have added no hardware drivers to the W7 machines to counter the MIDI, so am now just flummoxed...

Sound familiar anyone??

Thanks for your insights.
8 months ago
You say it worked OK under XP. I think you're saying it was OK under W7. You don't mention W8? However, it's not working under W10.

I understand that somewhere along this line, WinDoze did some messing with the MIDI system, among other things, the previous (much-loved ?) WinDoze Midi Mapper was removed.

Your problem may be connected with this.

You might try to install the CoolSoft Virtual Midi Synth (find it via web search, it's free download). This comes with the CoolSoft MIDI Mapper, which restores a replacement for the previous WinDoze MIDI mapper.

I have used the CoolSoft products myself, and they work fine. I've not used the MIDI mapper as I'm still using XP so I have no problems in this area.

If you install The CoolSoft product, and the mapper, and this then DOES allow you to see and use your interface as you could before, then this IS the problem - basically it's W10! If your system with this mapper loaded still does NOT see your interface, then there's a problem with the actual interface/cable/driver for it, and we need to look into that.

  • Page :
  • 1
There are no replies made for this post yet.
Be one of the first to reply to this post!